Devin's machines are failing to start or resume

Incident Report for Devin

Resolved

This incident has been resolved.
Posted May 29, 2026 - 09:49 UTC

Monitoring

New sessions will work properly. Sessions that started between 10 PM PT and 2:10 AM PT are affected and will still fail to save properly when suspending.
Posted May 29, 2026 - 09:26 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 29, 2026 - 08:01 UTC

Update

VM issues have been resolved. However, suspending and resuming of sessions may not work correctly at this time.
Posted May 29, 2026 - 07:53 UTC

Identified

The issue has been identified as an outage in an upstream provider and a fix is being implemented.

Dedicated deployment enterprise sessions are not affected.
Posted May 29, 2026 - 05:27 UTC
This incident affected: Agent.